Ruby2.1.2のソースインストール時に次のようなエラーが表示された

 

generating known_errors.inc

executable host ruby is required. use –with-baseruby option.

make: *** [known_errors.inc] エラー 1

 

RubyをインストールするにはRubyが必要とのことでした

が今まではRubyが入っていない状態でもインストールできていたので、ホストを再起動を試したらインストールできました。

思い当たる節がyum updateとyum groupinstall “Development Tools”を行ったということくらいしかありませんが、多分このせいなんだろうなぁ

Source: New feed